Service trucks can in extremely rare instances deadlock at baggage bay if no trailer is attached

Description

Additional note: I already reported this bug, but Olof asked me to report again. So, if you stumble across this thinking "I've seen this before." nevermind.
Actual bug report: I didn't take a look in my basement for quite a while when I found this mess (see screenshot). Dozens of Ramp Agents walking up and down next to the Baggage Bay while loading no baggage. When I dismantled the Baggage Bay they walked off to a Staff Room for a break, but the Baggage Trucks didn't move. I did rebuild the roads, added additional roads next to the trucks, tried this with Terminal Foundation underneath the roads and without foundation. Finally I was able to convince the one without trailers (the right one in the screenshot) and most of those on the left side (there is a huge pile of trucks overlapping each other) to move. But one of these trucks is not going anywhere, no matter what I do. At last I even tried the debug menu, but even this didn't help. This truck is stuck in the basement forever, may it rest in peace.

====================
COLLECTED HARDWARE DATA
====================

Application version: Beta 4.2-0

Device
=====

Model: OptiPlex 7010 (Dell Inc.)

Operating system: Windows 10 (10.0.0) 64bit

RAM size: 16 GB

Battery status: Charging
Battery level: -1

Processor device
============

Type: Intel(R) Core(TM) i5-3570 CPU @ 3.40GHz
Core count: 4
Frequency: 3 GHz

Grahpics device
===========

Vendor: NVIDIA
Type: NVIDIA GeForce GTX 1050 Ti
Memory size: 4 GB

Screen summary
===========

Full screen: True
Resolution: 1600 x 900 @ 60Hz

Checklists

None

Assignee

Olof

Reporter

Apoapsis Studios support

Labels

None

Operating System

Windows

Components

Affects versions

Priority

High